Author Topic: FTP error: No active Internet connection!  (Read 12721 times)

Offline detler

  • No flame
  • *
  • Posts: 2
  • Karma: +0/-0
FTP error: No active Internet connection!
« on: October 07, 2003, 03:04:57 AM »
When I try to publish, I get the following message:

Quote
Started Publish Process ...
No active Internet connection! Aborting ...


I am on a LAN, so I'm connected all the time.  Any ideas?  Thanks.

Offline Fahim

  • Administrator
  • Inferno
  • *****
  • Posts: 663
  • Karma: +4/-0
    • http://www.farook.org
FTP error: No active Internet connection!
« Reply #1 on: October 07, 2003, 10:18:57 AM »
Are you behind a firewall or a proxy perhaps?

Offline phil

  • No flame
  • *
  • Posts: 11
  • Karma: +0/-0
    • http://www.charliehamster.co.uk/
FTP error: No active Internet connection!
« Reply #2 on: October 07, 2003, 09:38:18 PM »
I have had this as well, ever since adding a modem to the computer. I'd much prefer Blog to publish over the LAN, but this doesn't seem to happen - Blog will only publish over the modem.

It's quite frustrating because the LAN route is obviously much faster, but is not always usable for things like Blog as large data transfers are frequent (hence the modem for smaller jobs).

Blog doesn't seem to recognise the existence of the LAN - the dial up related options in Blog are all disabled (I checked, thinking this was the problem).

Offline Tyran

  • Inferno
  • *****
  • Posts: 252
  • Karma: +1/-0
  • Grizzled Guru
    • The Whinery
FTP error: No active Internet connection!
« Reply #3 on: October 07, 2003, 10:47:52 PM »
This is probably OS related rather than Blog related.  IOW, Windows has probably set your modem connection to the be the default connection.  Check your connection tab under Internet Option in the Control Panel.

Offline detler

  • No flame
  • *
  • Posts: 2
  • Karma: +0/-0
FTP error: No active Internet connection!
« Reply #4 on: October 07, 2003, 10:57:25 PM »
I'm on a university LAN;  I suppose there could be a firewall, but I've tried the PASV option to no avail.  Other programs I use (Dreamweaver MX) do not require me to enter any firewall settings, so I'm pretty sure there is no firewall.  There is no proxy server.

I've checked the internet options under Win2k, and there are no dialup settings in place.

There is an "automatic configuration script" specified under Lan Settings.  Maybe that means something to you.

Any other ideas?

Offline Fahim

  • Administrator
  • Inferno
  • *****
  • Posts: 663
  • Karma: +4/-0
    • http://www.farook.org
FTP error: No active Internet connection!
« Reply #5 on: October 08, 2003, 09:37:38 AM »
Sounds as if the Internet connection detection routine I use has some bugs - or something :p I will have to send you a testing app that tries to log what is happening with the connection detection routine. Would you be willing to run it on your machine and let me know the results? If you are, then please e-mail me directly (my e-mail is on the site and in the Blog documentation ... though the one in the Blog documentation might be the old one that I don't use anymore ...) and I will send you the test app ...

Offline Wayfarer

  • Bonfire
  • ***
  • Posts: 100
  • Karma: +0/-0
    • La Bitacora del Caminante
FTP error: No active Internet connection!
« Reply #6 on: October 15, 2003, 07:13:14 PM »
Quote from: phil
I'd much prefer Blog to publish over the LAN, but this doesn't seem to happen - Blog will only publish over the modem.


Naaah!

I'm on a corporate LAN, I'm behind a firewall, and I have no modem now... and Blog runs smoothly except for that damn Corporate VirusScan that still checks every single file going out my PC...

So I bet the problem is the configuration or maybe the firewall if it's cutting traffic on port 21. Which OS are you using? Can you connect fine with a FTP client like WS_FTP? Do you have any sw that could interfere with your internet connection in some way? I'm thinking on sw like a firewall (Sygate Personal), an Antivirus (like Panda Platinum 7: it has an integrated firewall), a local proxy (Anonymizer, HTTPort) and so on.

This is an strange issue indeed...
My website: www.thewayfarer.info
My search site: www.cannotbefound.com
My music: www.amadian.com

Offline phil

  • No flame
  • *
  • Posts: 11
  • Karma: +0/-0
    • http://www.charliehamster.co.uk/
FTP error: No active Internet connection!
« Reply #7 on: October 16, 2003, 07:26:17 PM »
Quote from: Wayfarer
Quote from: phil
I'd much prefer Blog to publish over the LAN, but this doesn't seem to happen - Blog will only publish over the modem.


Naaah!

I'm on a corporate LAN, I'm behind a firewall, and I have no modem now... and Blog runs smoothly except for that damn Corporate VirusScan that still checks every single file going out my PC..


It publishes fine if I completely remove all trace of the modem. The LAN is not detected at all by Blog, but the local FTP server can be connected to from other machines as well as from a local command prompt.

As soon as the modem is added back in, Blog seems to recognise that a modem should be attached and available. If it isn't, then Blog throws a hissy fit without even looking at the LAN.

Quote

So I bet the problem is the configuration or maybe the firewall if it's cutting traffic on port 21. Which OS are you using? Can you connect fine with a FTP client like WS_FTP? Do you have any sw that could interfere with your internet connection in some way? I'm thinking on sw like a firewall (Sygate Personal), an Antivirus (like Panda Platinum 7: it has an integrated firewall), a local proxy (Anonymizer, HTTPort) and so on.

This is an strange issue indeed...


WinXP SP1, all WinXP post-SP1 updates :) See above for the rest.

Offline Fahim

  • Administrator
  • Inferno
  • *****
  • Posts: 663
  • Karma: +4/-0
    • http://www.farook.org
FTP error: No active Internet connection!
« Reply #8 on: October 17, 2003, 09:57:09 AM »
Phil, sorry about not getting back to you with a test program to sort out this problem ... will do so as soon as I can get around to it .. I promise :)

Offline Wayfarer

  • Bonfire
  • ***
  • Posts: 100
  • Karma: +0/-0
    • La Bitacora del Caminante
FTP error: No active Internet connection!
« Reply #9 on: October 17, 2003, 02:31:15 PM »
It sounds for me like a sort of routing problem in Windows XP. I have NT and I don't have any problem with the modem...

I'll try to bring my personal laptop (which runs XP and has internal modem) to my job, connect it to the corporate network and run Blog... Maybe that way we'll see what is happening.

Regards
My website: www.thewayfarer.info
My search site: www.cannotbefound.com
My music: www.amadian.com

Offline phil

  • No flame
  • *
  • Posts: 11
  • Karma: +0/-0
    • http://www.charliehamster.co.uk/
FTP error: No active Internet connection!
« Reply #10 on: October 31, 2003, 03:02:05 PM »
Quote from: Fahim
Phil, sorry about not getting back to you with a test program to sort out this problem ... will do so as soon as I can get around to it .. I promise :)


As and when you mail it, I'll be able to help you locate the problem :)

Offline Fahim

  • Administrator
  • Inferno
  • *****
  • Posts: 663
  • Karma: +4/-0
    • http://www.farook.org
FTP error: No active Internet connection!
« Reply #11 on: November 01, 2003, 10:50:30 AM »
LOL. I see you are gently reminding me that I still haven't sent it to you :p Sorry, got totally sidetracked by a million other things ... will try to do that this weekend ...

Offline phil

  • No flame
  • *
  • Posts: 11
  • Karma: +0/-0
    • http://www.charliehamster.co.uk/
FTP error: No active Internet connection!
« Reply #12 on: November 05, 2003, 11:59:53 PM »
Any chance this is already resolved in Blog 8?

Offline Fahim

  • Administrator
  • Inferno
  • *****
  • Posts: 663
  • Karma: +4/-0
    • http://www.farook.org
FTP error: No active Internet connection!
« Reply #13 on: November 06, 2003, 09:09:49 AM »
Ugh .. I still haven't sent you that test program, have I? I keep on meaning to but something or other comes up ... sorry :-( And no, it's not resolved in Blog 8.0 because I still have no idea what the problem is ....

Offline phil

  • No flame
  • *
  • Posts: 11
  • Karma: +0/-0
    • http://www.charliehamster.co.uk/
FTP error: No active Internet connection!
« Reply #14 on: November 13, 2003, 11:24:07 PM »
No test program has appeared in my inbox yet :(