Author Topic: WP upgrade > Blacklist not working  (Read 5405 times)

Offline Chanty

  • No flame
  • *
  • Posts: 1
  • Karma: +0/-0
WP upgrade > Blacklist not working
« on: February 23, 2005, 12:03:44 AM »
I've just upgraded my Wordpress from 1.2 to 1.5, and I uploaded all the Blacklist files. I also activated it, but when I want to go to Blacklist Config, I get this error:

Code: [Select]
Fatal error: Call to a member function on a non-object in /home/chanty87/public_html/zb/news/wp-admin/wpblacklist.php on line 89
Before I upgraded, everything worked fine... What's the problem?  :|
« Last Edit: February 23, 2005, 12:08:10 AM by Chanty »

Offline Fahim

  • Administrator
  • Inferno
  • *****
  • Posts: 663
  • Karma: +4/-0
    • http://www.farook.org
Re: WP upgrade > Blacklist not working
« Reply #1 on: February 23, 2005, 03:01:03 PM »
The problem unfortunately is that they changed stuff around in WP 1.5 and I still haven't had the time to come up with a new release which is compatible with WP 1.5.  I believe that somebody had mentioned somewhere that if you remove the calls to magic_quotes_gpc (I believe that's the function .. but I"m typing from memory ...) from all the WPBlacklist files, it works fine with WP 1.5. Of course, that was for the pre-release versions, not sure if that holds true even now. I will try to put out a new release of WPBlacklist as soon as I get the chance.