Author Topic: Problems with WPBlacklist 2.9  (Read 6488 times)

Offline slave0

  • No flame
  • *
  • Posts: 2
  • Karma: +0/-0
Problems with WPBlacklist 2.9
« on: March 01, 2005, 09:19:51 AM »
hio~

i'm using WP1.5, and installed the 2.9 version of the black list

several problems:

1. when i run the installer, after the first step, i get these messages:

Warning: file(): URL file-access is disabled in the server configuration in /var/www/domains/x.victorox.com/docs/blacklist-install.php on line 87

Warning: file(http://www.jayallen.org/comment_spam/blacklist.txt): failed to open stream: no suitable wrapper could be found in /var/www/domains/x.victorox.com/docs/blacklist-install.php on line 87
All done!

ok...i tried the configuration, all looks ok, then i went to search my blog using the blacklist and this is what i get:

Warning: No ending delimiter '/' found in /var/www/domains/x.victorox.com/docs/wp-admin/wpblsearch.php on line 200

Warning: No ending delimiter '/' found in /var/www/domains/x.victorox.com/docs/wp-admin/wpblsearch.php on line 204

Warning: No ending delimiter '/' found in /var/www/domains/x.victorox.com/docs/wp-admin/wpblsearch.php on line 208

i looked at the coding for wpblsearch.php, these 3 lines are the ones matching the comment author, email url to those in the black list. i checked my blacklist, and all the "/" are prefixed by "\".

any ideas?

Offline Fahim

  • Administrator
  • Inferno
  • *****
  • Posts: 663
  • Karma: +4/-0
    • http://www.farook.org
Re: Problems with WPBlacklist 2.9
« Reply #1 on: March 01, 2005, 06:11:16 PM »
The first error, the installation one, is a PHP configuration issue on your server - so nothing much I can do :p

The second one, see if you have any URL's which end in a "\" (yes, I mean a "\" and not a "/" :p) Some of the comment spammers seem to use a "\" and if you have harvesting enabled, this seems to get added to your blacklist and that creates a problem as well. Not sure if I added code into circumvent this, I meant to ... but might have forgotten :p

Offline slave0

  • No flame
  • *
  • Posts: 2
  • Karma: +0/-0
Re: Problems with WPBlacklist 2.9
« Reply #2 on: March 01, 2005, 08:12:45 PM »
The first error, the installation one, is a PHP configuration issue on your server - so nothing much I can do :p

The second one, see if you have any URL's which end in a "\" (yes, I mean a "\" and not a "/" :p) Some of the comment spammers seem to use a "\" and if you have harvesting enabled, this seems to get added to your blacklist and that creates a problem as well. Not sure if I added code into circumvent this, I meant to ... but might have forgotten :p

any idea what i can do for the first error? e.g. CHMOD, etc?

as for the 2nd one, i looked thru the database, lo and behold, there are some entries with a single "\". So what i did was to prefix that with a "\" (thus ending with "\\" ) and the warning vanished  :-D

many thanks for the info!

and kudos for the WPBlacklist, i only have this spam plugin installed, and i don't have any problems with spam!  :lol:

Offline Fahim

  • Administrator
  • Inferno
  • *****
  • Posts: 663
  • Karma: +4/-0
    • http://www.farook.org
Re: Problems with WPBlacklist 2.9
« Reply #3 on: March 02, 2005, 04:39:29 PM »
From the path given in the error, it looks as if you are in a shared hosting environment. So, if you don't have control of your server, then you'd probably have to talk to the support staff at your hosting company and provide them with this particular error. Hopefully, they'll know which configuration option needs to be changed :p