Author Topic: Blog 8 Beta 7 upgrade bug  (Read 5564 times)

Offline Wayfarer

  • Bonfire
  • ***
  • Posts: 100
  • Karma: +0/-0
    • La Bitacora del Caminante
Blog 8 Beta 7 upgrade bug
« on: September 14, 2007, 08:41:51 PM »
Hi there,

There's a bug while trying to upgrade from Blog 7.1 to Blog 8 Beta 7. When you try to run the program for the first time after the installation it asks you for a backup before converting the databases to the new version. Whether you perform the backup or not, the next message you see is an error message saying that "blog.dat cannot be found" and the conversion process is aborted. The exe file remains active and loaded in memory and you need to kill the process in Windows' Task Manager.

This only happens while upgrading from Blog 7.1 to Blog 8 Beta 7, but not when upgrading from any other Blog 8 Beta version... So the workaround is quite simple: just install Blog 8 Beta 5 instead of Beta 7. Convert the databases to the new format with Beta 5, then install Beta 7 and convert again the databases. This has worked smooth for me.

Hope this will help if someone finds the same issue.

Regards,

-- Wayfarer
My website: www.thewayfarer.info
My search site: www.cannotbefound.com
My music: www.amadian.com